Midnight Voices (http://www.peteatkin.com/cgi-bin/mv/YaBB.cgi)
Atkin admin >> Tech >> Tech help Yabb
(Message started by: Cary on Today at 11:36)

Title: Tech help Yabb
Post by Cary on Today at 11:36
I'm just setting up a forum for work using Yabb (v 2.1). Got it up and working pretty much now. But - how do you/can you turn off the "users online" at the bottom of the home page?

And while I'm here ..... can you change the layout of the message write screens? (this one I'm on now). This looks a lot neater than mine but I'm not sure if that's my set up or just because it's Yabb v2.1

Thanks

Title: Re: Tech help Yabb
Post by S J Birkill on Today at 12:06
Hi Cary

Most of the cosmetic and operational changes I've made to adapt YaBB 1.3 to my own preferences have been done at Perl code level (tough for a non-computer scientist like me!), plus I've added a few 'mods' developed by other users. You can change pretty much anything you like, but unless it's a built-in option or a standard mod it'll involve learning the syntax of Perl and being prepared to edit more than one module of source code.

I expect YaBB 2 to have been a major re-write, so it would be dangerous I think to extrapolate any specifics from YaBB 1.3. I suggest you consult the various on-line forums which exist to answer questions just like yours, e.g.:

http://www.yabbforum.com/community/ (http://www.yabbforum.com/community/)
http://www.theadminzone.com/forums/showthread.php?t=14719 (http://www.theadminzone.com/forums/showthread.php?t=14719)
http://www.boardmod.org/ (http://www.boardmod.org/)

Steve

Title: Re: Tech help Yabb
Post by Cary on Today at 12:19
Thanks Steve - do you know if it is possible to turn it off (the 'Users online' that is) in v1.3? If it is I should be able to find how to do it in v2.1  If not I'll stop looking for now.

Perl!! I haven't even got to grips with HTML and I never made it past getting a bouncing ball on the C64 - I gave up on programming after that triumph!!   :-/

Title: Re: Tech help Yabb
Post by S J Birkill on Today at 12:32
Doesn't look like it's an option under "Forum preferences and settings". What I'd do (strictly in my version of 1.3!!!) is delete (or comment out) the HTML table row (with embedded Perl code) :


Code:
<tr>
<td class="windowbg" bgcolor="$color{'windowbg'}" width="20" valign="middle" align="center"><img src="$imagesdir/online.gif" border="0" alt=""></td>
<td class="windowbg2" bgcolor="$color{'windowbg2'}"><font size=1>
<table width="98%" cellpadding="3" align="center">
<tr>
<td valign="top" align="left"><font size="1">~;
if ($guests == 1) {
$yymain .=qq~1 Guest, ~;
}
else {
$yymain .=qq~$guests Guests, ~;
}
if ($numusers == 1) {
$yymain .=qq~1 Member~;
}
else {
$yymain .=qq~$numusers Members~;
}
if ($numusers > 0) {
$yymain .=qq~ :~;
}
$yymain .=qq~ $users
</font></td>
</tr>
</table>
</font></td>
</tr>

...in module /Sources/BoardIndex.pl.

But you really didn't want to know that.

SJB

Title: Re: Tech help Yabb
Post by Cary on Today at 13:17
You were right! I didn't want to know that  :o And couldn't find those lines in my code so I'll have to see if I can find something similar - which could take some time.

Thanks for your help Steve



Midnight Voices » Powered by YaBB 1 Gold - SP 1.3.1!
YaBB 2000-2003. All Rights Reserved.